Keine Maus unter XenServer 6.1 / 6.2 und Windows Server 2012 R2

Obwohl Windows Server 2012 R2 erst seit XenServer 6.2 SP1 offiziell unterstützt wird, konnte die Windows-Version ohne Probleme auch auf älteren Versionen von XenServer installiert werden. Insbesondere unter XenServer 6.1 und 6.2 kommt es aber öfter zu Problemen mit der Maus. Entweder ist die Maus überhaupt nicht vorhanden und kann daher auch nicht verwendet werden oder die Bedienung ist extrem zäh und hakelig. Beide Probleme können sowohl via Konsole als auch per Remotedesktopverbindung auftreten, müssen aber nicht zwangsweise parallel auftreten. Ebenso tauchen die Probleme unabhängig davon auf, ob die XenServer Tools installiert sind oder nicht.

Im Geräte-Manager der betroffenen VM ist der „Intel(R) 82371SB PCI to USB Universal Host Controller“ mit einem gelben Ausrufezeichen versehen (siehe Screenshot). Ursache sind höchstwahrscheinlich Kompatibilitätsprobleme zwischen der von QEMU emulierten USB-Maus und dem USB-Stack von Windows Server 2012 R2.

Zur Lösung der Maus-Probleme muss der „Intel(R) 82371SB PCI to USB Universal Host Controller“ deinstalliert werden. Anschließend muss im Geräte-Manager nach geänderter Hardware gesucht werden. Der „Intel(R) 82371SB PCI to USB Universal Host Controller“ wird neu erkannt und auch die Maus ist jetzt funktionstüchtig. Es ist kein Neustart notwendig.

Leider kann der Fehler erneut auftreten. In diesem Fall muss das oben beschriebene Vorgehen wiederholt werden.

Tobi

Hallo, mein Name ist Tobias und ich habe diesen Blog im April 2009 ins Leben gerufen. Seitdem blogge ich hier über Software, Internet, Windows und andere Themen, die mich interessieren. SSDblog ist mein zweiter Blog, indem es rund um das Thema SSDs geht. Ich würde mich freuen, wenn ihr meinen Feed abonniert oder mir auf Twitter, Facebook, Google+ und Google+ (privat) folgt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.